Back to overview

Project Manager and Time Logger are down

Sep 9, 2024 at 4:17am UTC
Affected services
Time Logger

Resolved
Sep 11, 2024 at 11:40pm UTC

Tony is looking into this

Created
Sep 9, 2024 at 4:17am UTC

Time Logger recovered.